Issue
Sometimes when creating a booking or quote on your SmartLM system you'll get a warning that an address does not appear to be valid.
Cause
When using the Address Lookup tool built into SmartLM, we use the Google "Places" directory. This directory is comprised of both residential addresses, but also business addesses added via the Google Business tools. As part of this when a business adds themselves to Google they're asked to input the address but no actual validation of this address is done.
When the booking or quote is then saved, we check a different Google Address directory which is used to calculate distances for pricing and ETAs.
If the address the business put in on Google isn't a valid address, when we then do these calculations Google responds that it's invalid.
Solution
We suggest doing one of the following in these cases to resolve the issue.
- Search just the postcode itself on Google, usually you should then see an area drawn on the map for this postcode area. If just a single business appears this is usually an indication that they've typed the postcode in wrong.
- Check other addresses nearby, we've seen in a few cases that the addresses next door to the incorrect one are usually a different address, which is usually the correct one.
- Check the Royal Mail address lookup tool, because this isn't using Googles database this can be good to verify if it actually is valid or not. https://www.royalmail.com/find-a-postcode
Then update the address manually with the new details.
Alternatively whilst not recommended you can still create a booking without the address being valid, but you'll need to manually do the distance & pricing calculations.
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